Service Degradation - Investigating

Minor incident SMS Notify V2 SMS
2023-10-16 19:14 BST · 32 minutes

Updates

Resolved

International route latency resolved.

October 16, 2023 · 19:41 BST
Investigating

Esendex US is investigating latency with some international routes.

October 16, 2023 · 19:14 BST

← Back