Service Degradation

Major incident SMS Notify V2 Binds SMS API MMS DLR Postbacks/Webhooks Dash Notify Website Binds SMS API MMS DLR Postbacks/Webhooks
2025-01-10 07:20 AM EST · 9 hours, 46 minutes

Updates

Resolved

The Permanent fix for the message status API Call issue has been placed into production and being monitored by our staff. At this time, customers who use the message status calls should begin receiving valid data in return.

https://esendex.us/docs/sms-api/api/methods/ReadIncomingMessages/
https://esendex.us/docs/sms-api/api/methods/ReadMessageStatus/

This will serve as the final update for this incident. We apologize for any inconvenience this has caused.

January 10, 2025 · 04:56 PM EST
Update

A permanent fix to address the message status API calls is currently going through our Testing and QA Process. Once completed we will release this fix to our production environments and re-enable the Message Status API calls. We will post another update after the currently disabled API calls return to service.

We apologize for any issues this is causing our customers. We are working as quickly as possible to address these issues and return to normal operations.

January 10, 2025 · 04:02 PM EST
Update

The issue which caused delays on our messaging platform has been mitigated. At this time, the we have limited our customers ability to pull message status via our API. The following API calls will be returning invalid results until further notice:

https://esendex.us/docs/sms-api/api/methods/ReadIncomingMessages/
https://esendex.us/docs/sms-api/api/methods/ReadMessageStatus/

We are working to resolve the issue that caused these API Calls to create issues within the platform prior to re-enabling this functionality. Further updates will be posted on this page.

We apologize for any issues this is causing our customers. We are working as quickly as possible to address these issues and return to normal operations.

January 10, 2025 · 12:12 PM EST
Escalate

We are still experiencing technical issues with our messaging platform. Our engineers are working on resolving the issue and we expect to be fully operational again soon.

We’re sorry that this is happening. Please direct any queries to our support team.

January 10, 2025 · 10:10 AM EST
Investigating

We are currently experiencing some temporary technical issues which may be affecting some of our customers’ ability to send or receive messages; in some cases this may also include gaining access to any of our services.

We’re sorry that this is happening. Thank you for your continued patience and support while we work to resolve this.

Please direct any queries to our support team.

January 10, 2025 · 08:30 AM EST

← Back